summaryrefslogtreecommitdiff
path: root/debian/autobake-deb.sh
diff options
context:
space:
mode:
Diffstat (limited to 'debian/autobake-deb.sh')
-rwxr-xr-xdebian/autobake-deb.sh11
1 files changed, 10 insertions, 1 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 1cc215f1c82..09b06084647 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -17,6 +17,7 @@ set -e
export DEB_BUILD_OPTIONS="nocheck $DEB_BUILD_OPTIONS"
source ./VERSION
+
# General CI optimizations to keep build output smaller
if [[ $GITLAB_CI ]]
then
@@ -34,7 +35,7 @@ then
then
cp -v storage/columnstore/columnstore/debian/mariadb-plugin-columnstore.* debian/
echo >> debian/control
- cat storage/columnstore/columnstore/debian/control >> debian/control
+ sed "s/10.6/${MYSQL_VERSION_MAJOR}.${MYSQL_VERSION_MINOR}/" <storage/columnstore/columnstore/debian/control >> debian/control
fi
fi
@@ -67,6 +68,12 @@ disable_pmem()
sed '/-DWITH_PMEM=YES/d' -i debian/rules
}
+disable_libfmt()
+{
+ # 0.7+ required
+ sed '/libfmt-dev/d' -i debian/control
+}
+
architecture=$(dpkg-architecture -q DEB_BUILD_ARCH)
# Parse release name and number from Linux standard base release
@@ -105,6 +112,7 @@ in
disable_pmem
;&
buster)
+ disable_libfmt
replace_uring_with_aio
if [ ! "$architecture" = amd64 ]
then
@@ -134,6 +142,7 @@ in
;&
focal)
replace_uring_with_aio
+ disable_libfmt
;&
impish|jammy|kinetic)
# mariadb-plugin-rocksdb s390x not supported by us (yet)