summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 7 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 3b1952ad2b9..809911d4179 100755
--- a/debian/rules
+++ b/debian/rules
@@ -86,9 +86,6 @@ endif
$${MYSQL_COMPILER_LAUNCHER:+-DCMAKE_C_COMPILER_LAUNCHER=${MYSQL_COMPILER_LAUNCHER}} \
-DCMAKE_SYSTEM_PROCESSOR=$(DEB_BUILD_ARCH) \
-DBUILD_CONFIG=mysql_release \
- -DINSTALL_LIBDIR=lib/$(DEB_HOST_MULTIARCH) \
- -DINSTALL_PLUGINDIR=lib/mysql/plugin \
- -DINSTALL_MYSQLTESTDIR=share/mysql/mysql-test \
-DDEB=$(DISTRIBUTION) ..'
touch $@
@@ -124,8 +121,13 @@ endif
cp $(BUILDDIR)/support-files/mariadb.service debian/mariadb-server-10.2.mariadb.service
cp $(BUILDDIR)/support-files/mariadb@.service debian/mariadb-server-10.2.mariadb@.service
- # make install
- cd $(BUILDDIR) && $(MAKE) install DESTDIR=$(TMP)
+ # Run 'make install' without output since it is uninteresting and
+ # silencing it helps to make overall build log shorter and more readable
+ @echo "Running $(MAKE) install DESTDIR=$(TMP) ..."
+ cd $(BUILDDIR) && $(MAKE) install DESTDIR=$(TMP) > /dev/null
+
+ # If mariadb-test package is removed, also remove most of it's files
+ grep --quiet "Package: mariadb-test" debian/control || rm -rf $(TMP)/usr/share/mysql/mysql-test
# Delete runnable files we don't want to have in the test data package.
# This avoids triggering multiple Lintian errors.