summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh10
1 files changed, 10 insertions, 0 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 198cba8a467..bdb5535da99 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -72,6 +72,16 @@ then
sed '/mariadb-service-convert/d' -i debian/mariadb-server-10.2.install
fi
+# Convert gcc version to numberical value. Format is Mmmpp where M is Major
+# version, mm is minor version and p is patch.
+GCCVERSION=$(gcc -dumpversion | sed -e 's/\.\([0-9][0-9]\)/\1/g' -e 's/\.\([0-9]\)/0\1/g' -e 's/^[0-9]\{3,4\}$/&00/')
+# Don't build rocksdb package if gcc version is less than 4.8 or we are running on
+# x86 32 bit.
+if [ $GCCVERSION -lt 40800 ] || [ $(uname -i) -eq "i386" ] || [$(uname -i) -eq "i486"]
+then
+ sed '/Package: mariadb-plugin-rocksdb/,+7d' -i debian/control
+fi
+
# Adjust changelog, add new version
echo "Incrementing changelog and starting build scripts"