summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh7
1 files changed, 3 insertions, 4 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index f53439340a4..1a43c064468 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -84,10 +84,9 @@ if [[ $GCCVERSION -lt 40800 ]] || [[ $(arch) =~ i[346]86 ]]
then
sed '/Package: mariadb-plugin-rocksdb/,/^$/d' -i debian/control
fi
-if [[ $GCCVERSION -lt 40800 ]]
-then
- sed '/Package: mariadb-plugin-aws-key-management-10.2/,/^$/d' -i debian/control
-fi
+
+# Always remove aws plugin, see -DNOT_FOR_DISTRIBUTION in CMakeLists.txt
+sed '/Package: mariadb-plugin-aws-key-management-10.2/,/^$/d' -i debian/control
# Don't build cassandra package if thrift is not installed
if [[ ! -f /usr/local/include/thrift/Thrift.h && ! -f /usr/include/thrift/Thrift.h ]]