summaryrefslogtreecommitdiff
path: root/extra/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'extra/Makefile.am')
-rw-r--r--extra/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/extra/Makefile.am b/extra/Makefile.am
index bc7289c7f7d..75422c4ee11 100644
--- a/extra/Makefile.am
+++ b/extra/Makefile.am
@@ -43,7 +43,12 @@ $(top_builddir)/include/mysqld_ername.h: $(top_builddir)/include/mysqld_error.h
$(top_builddir)/include/sql_state.h: $(top_builddir)/include/mysqld_error.h
bin_PROGRAMS = replace perror resolveip my_print_defaults \
- resolve_stack_dump mysql_waitpid innochecksum
+ resolve_stack_dump mysql_waitpid
+# "innochecksum" should be switched
+if BUILD_INNODB_TOOLS
+bin_PROGRAMS += innochecksum
+endif
+
noinst_PROGRAMS = charset2html
EXTRA_PROGRAMS = comp_err
EXTRA_DIST = CMakeLists.txt