summaryrefslogtreecommitdiff
path: root/extra/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'extra/Makefile.am')
-rw-r--r--extra/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/extra/Makefile.am b/extra/Makefile.am
index df29a3a6ab7..1e720474784 100644
--- a/extra/Makefile.am
+++ b/extra/Makefile.am
@@ -14,11 +14,21 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-INCLUDES = @MT_INCLUDES@ -I$(top_srcdir)/include @ndbcluster_includes@
+INCLUDES = @MT_INCLUDES@ -I$(top_srcdir)/include \
+ @ndbcluster_includes@ -I$(top_srcdir)/sql
LDADD = @CLIENT_EXTRA_LDFLAGS@ ../mysys/libmysys.a \
../dbug/libdbug.a ../strings/libmystrings.a
bin_PROGRAMS = replace comp_err perror resolveip my_print_defaults \
- resolve_stack_dump mysql_waitpid
+ resolve_stack_dump mysql_waitpid mysql_tzinfo_to_sql
+
+mysql_tzinfo_to_sql_SOURCES = tztime.cc
+mysql_tzinfo_to_sql_CXXFLAGS = -DTZINFO2SQL $(AM_CXXFLAGS)
+mysql_tzinfo_to_sql_LDADD = $(LDADD) $(CXXLDFLAGS)
+
+tztime.cc:
+ rm -f $(srcdir)/tztime.cc; \
+ @LN_CP_F@ $(top_srcdir)/sql/tztime.cc $(srcdir)/tztime.cc
+
# Don't update the files from bitkeeper
%::SCCS/s.%