summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am53
1 files changed, 53 insertions, 0 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
new file mode 100644
index 00000000000..8ba6ea9d41e
--- /dev/null
+++ b/include/Makefile.am
@@ -0,0 +1,53 @@
+# Copyright (C) 2000 MySQL AB & MySQL Finland AB & TCX DataKonsult AB
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this library; if not, write to the Free
+# Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
+# MA 02111-1307, USA
+
+BUILT_SOURCES = my_config.h mysql_version.h m_ctype.h
+pkginclude_HEADERS = dbug.h m_string.h my_sys.h mysql.h mysql_com.h \
+ mysqld_error.h my_list.h \
+ my_pthread.h my_no_pthread.h raid.h errmsg.h \
+ my_config.h my_global.h my_net.h \
+ sslopt-case.h sslopt-longopts.h sslopt-usage.h \
+ sslopt-vars.h $(BUILT_SOURCES)
+noinst_HEADERS = global.h config-win.h \
+ nisam.h heap.h merge.h \
+ myisam.h myisampack.h myisammrg.h ft_global.h\
+ my_dir.h mysys_err.h my_base.h \
+ my_nosys.h my_alarm.h queues.h \
+ my_tree.h hash.h thr_alarm.h thr_lock.h \
+ getopt.h t_ctype.h violite.h \
+ mysql_version.h.in
+
+# mysql_version.h are generated
+SUPERCLEANFILES = mysql_version.h
+
+# Some include files that may be moved and patched by configure
+DISTCLEANFILES = $(distdir)/sched.h
+
+all-local: my_config.h my_global.h
+
+# Since we include my_config.h it better exist from the beginning
+my_config.h: ../config.h
+ $(CP) ../config.h my_config.h
+
+# This should be changed in the source and removed.
+my_global.h: global.h
+ $(CP) global.h my_global.h
+
+# These files should not be included in distributions since they are
+# generated by configure from the .h.in files
+dist-hook:
+ rm -f $(distdir)/mysql_version.h $(distdir)/my_config.h