summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 15f1a83c79d..990954b7cbf 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -16,7 +16,7 @@
# MA 02111-1307, USA
# FIXME 'abi_check' should be in BUILT_SOURCES, disabled for now
-BUILT_SOURCES = $(HEADERS_GEN)
+BUILT_SOURCES = $(HEADERS_GEN) link_sources
HEADERS_GEN = mysql_version.h my_config.h
HEADERS_ABI = mysql.h mysql_com.h mysql_time.h \
my_list.h my_alloc.h typelib.h
@@ -48,9 +48,10 @@ EXTRA_DIST = mysql_h.ic
DISTCLEANFILES = sched.h $(CLEANFILES)
link_sources:
- -$(RM) -fr readline
+ -$(RM) -f readline openssl
@readline_h_ln_cmd@
@yassl_h_ln_cmd@
+ echo timestamp > link_sources
my_config.h: ../config.h
$(CP) ../config.h my_config.h