summaryrefslogtreecommitdiff
path: root/libmysql_r/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libmysql_r/Makefile.am')
-rw-r--r--libmysql_r/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/libmysql_r/Makefile.am b/libmysql_r/Makefile.am
index 4a37dcfdec9..94b66f29419 100644
--- a/libmysql_r/Makefile.am
+++ b/libmysql_r/Makefile.am
@@ -20,9 +20,11 @@
#
# This file is public domain and comes with NO WARRANTY of any kind
-target = libmysqlclient_r.la
-target_defs = -DDONT_USE_RAID -DMYSQL_CLIENT @LIB_EXTRA_CCFLAGS@
-LIBS = @LIBS@ @ZLIB_LIBS@ @openssl_libs@
+target = libmysqlclient_r.la
+target_defs = -DDISABLE_MYSQL_PRLOCK_H -DDONT_USE_RAID \
+ -DMYSQL_CLIENT @LIB_EXTRA_CCFLAGS@
+
+LIBS = @LIBS@ @ZLIB_LIBS@ @openssl_libs@
INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include \
$(openssl_includes) @ZLIB_INCLUDES@