summaryrefslogtreecommitdiff
path: root/libmysql_r/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libmysql_r/Makefile.am')
-rw-r--r--libmysql_r/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/libmysql_r/Makefile.am b/libmysql_r/Makefile.am
new file mode 100644
index 00000000000..424e6bdf854
--- /dev/null
+++ b/libmysql_r/Makefile.am
@@ -0,0 +1,39 @@
+# Copyright (C) 2000 MySQL AB & MySQL Finland AB & TCX DataKonsult AB
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this library; if not, write to the Free
+# Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
+# MA 02111-1307, USA
+
+# This file is public domain and comes with NO WARRANTY of any kind
+
+target = libmysqlclient_r.la
+target_defs =
+## LIBS = @LIBS@
+
+## automake barfs if you don't use $(srcdir) or $(top_srcdir) in include
+include $(top_srcdir)/libmysql/Makefile.shared
+
+libmysql_dir = $(top_srcdir)/libmysql
+
+libmysqlclient_r_la_SOURCES = $(target_sources)
+libmysqlclient_r_la_LIBADD = $(target_libadd)
+libmysqlclient_r_la_LDFLAGS = $(target_ldflags)
+
+# This is called from the toplevel makefile
+link_sources:
+ set -x; \
+ for f in `cd $(libmysql_dir) && echo *.[ch]`; do \
+ rm -f $(srcdir)/$$f; \
+ @LN_CP_F@ $(libmysql_dir)/$$f $(srcdir)/$$f; \
+ done