summaryrefslogtreecommitdiff
path: root/libmysqld/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libmysqld/CMakeLists.txt')
-rw-r--r--libmysqld/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/libmysqld/CMakeLists.txt b/libmysqld/CMakeLists.txt
index c071356715f..76ed13acf40 100644
--- a/libmysqld/CMakeLists.txt
+++ b/libmysqld/CMakeLists.txt
@@ -150,12 +150,13 @@ ENDIF()
# async (*_start/*_cont functions)
SET(EMBEDDED_API)
-FOREACH(f ${CLIENT_API})
+
+FOREACH(f ${CLIENT_API_FUNCTIONS})
+ #IF(NOT(f MATCHES "plugin") AND NOT (f MATCHES "_start$") AND NOT (f MATCHES "_cont$"))
IF(NOT(f MATCHES "plugin|_start$|_cont$"))
- SET(EMBEDDED_API ${EMBEDDED_API) ${f})
+ SET(EMBEDDED_API ${EMBEDDED_API} ${f})
ENDIF()
ENDFOREACH()
-MESSAGE("embedded api=${EMBEDDED_API}")
IF(NOT DISABLE_SHARED)
MERGE_LIBRARIES(libmysqld SHARED mysqlserver EXPORTS ${EMBEDDED_API}