summaryrefslogtreecommitdiff
path: root/libmysqld/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libmysqld/examples/Makefile.am')
-rw-r--r--libmysqld/examples/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/libmysqld/examples/Makefile.am b/libmysqld/examples/Makefile.am
index 0bd3f06a9f3..bbfa4d87181 100644
--- a/libmysqld/examples/Makefile.am
+++ b/libmysqld/examples/Makefile.am
@@ -21,14 +21,15 @@ tests_sources = $(mysql_client_test_embedded_SOURCES)
CLEANFILES = $(client_sources) $(tests_sources)
link_sources:
+ set -x; \
for f in $(client_sources); do \
- rm -f $(srcdir)/$$f; \
- @LN_CP_F@ $(srcdir)/../../client/$$f $(srcdir)/$$f; \
- done;
+ rm -f $$f; \
+ @LN_CP_F@ $(top_srcdir)/client/$$f $$f; \
+ done; \
for f in $(tests_sources); do \
- rm -f $(srcdir)/$$f; \
- @LN_CP_F@ $(srcdir)/../../tests/$$f $(srcdir)/$$f; \
- done;
+ rm -f $$f; \
+ @LN_CP_F@ $(top_srcdir)/tests/$$f $$f; \
+ done
DEFS = -DEMBEDDED_LIBRARY
INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(srcdir) \