summaryrefslogtreecommitdiff
path: root/libservices/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libservices/CMakeLists.txt')
-rw-r--r--libservices/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/libservices/CMakeLists.txt b/libservices/CMakeLists.txt
index 79431ff65fe..396430fba12 100644
--- a/libservices/CMakeLists.txt
+++ b/libservices/CMakeLists.txt
@@ -15,7 +15,11 @@
INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include)
-SET(MYSQLSERVICES_SOURCES my_snprintf_service.c thd_alloc_service.c)
+SET(MYSQLSERVICES_SOURCES
+ my_snprintf_service.c
+ thd_alloc_service.c
+ thd_wait_service.c
+ my_thread_scheduler_service.c)
ADD_LIBRARY(mysqlservices ${MYSQLSERVICES_SOURCES})
INSTALL(TARGETS mysqlservices DESTINATION ${INSTALL_LIBDIR})