summaryrefslogtreecommitdiff
path: root/man/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'man/CMakeLists.txt')
-rw-r--r--man/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/man/CMakeLists.txt b/man/CMakeLists.txt
index 135d66634e4..4987a5bee61 100644
--- a/man/CMakeLists.txt
+++ b/man/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright (c) 2006, 2010, Oracle and/or its affiliates. All rights reserved.
+# Copyright (c) 2006, 2011, Oracle and/or its affiliates. All rights reserved.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -16,15 +16,23 @@
# Copy man pages
FILE(GLOB MAN1_FILES *.1)
FILE(GLOB MAN1_EXCLUDE make_win_bin_dist.1)
+FILE(GLOB MAN1_NDB ndb*.1)
FILE(GLOB MAN8_FILES *.8)
+FILE(GLOB MAN8_NDB ndb*.8)
IF(MAN1_FILES)
IF(MAN1_EXCLUDE)
LIST(REMOVE_ITEM MAN1_FILES ${MAN1_EXCLUDE})
ENDIF()
+ IF(MAN1_NDB)
+ LIST(REMOVE_ITEM MAN1_FILES ${MAN1_NDB})
+ ENDIF()
INSTALL(FILES ${MAN1_FILES} DESTINATION ${INSTALL_MANDIR}/man1
COMPONENT ManPages)
ENDIF()
IF(MAN8_FILES)
+ IF(MAN8_NDB)
+ LIST(REMOVE_ITEM MAN8_FILES ${MAN8_NDB})
+ ENDIF()
INSTALL(FILES ${MAN8_FILES} DESTINATION ${INSTALL_MANDIR}/man8
COMPONENT ManPages)
ENDIF()