summaryrefslogtreecommitdiff
path: root/mysql-test/ndb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mysql-test/ndb/Makefile.am')
-rw-r--r--mysql-test/ndb/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/mysql-test/ndb/Makefile.am b/mysql-test/ndb/Makefile.am
new file mode 100644
index 00000000000..3ed222344a6
--- /dev/null
+++ b/mysql-test/ndb/Makefile.am
@@ -0,0 +1,23 @@
+
+benchdir_root= $(prefix)
+testdir = $(benchdir_root)/mysql-test/ndb
+
+test_SCRIPTS = ndbcluster
+
+noinst_HEADERS = ndbcluster.sh
+
+dist_test_DATA = ndb_config_2_node.ini
+
+SUFFIXES = .sh
+
+.sh:
+ @RM@ -f $@ $@-t
+ @SED@ \
+ -e 's!@''ndbbindir''@!$(ndbbindir)!g' \
+ -e 's!@''ndbtoolsdir''@!$(ndbtoolsdir)!g' \
+ $< > $@-t
+ @CHMOD@ +x $@-t
+ @MV@ $@-t $@
+
+# Don't update the files from bitkeeper
+%::SCCS/s.%