summaryrefslogtreecommitdiff
path: root/ndb/src/mgmclient/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ndb/src/mgmclient/Makefile.am')
-rw-r--r--ndb/src/mgmclient/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/ndb/src/mgmclient/Makefile.am b/ndb/src/mgmclient/Makefile.am
new file mode 100644
index 00000000000..f3eaaaa68bd
--- /dev/null
+++ b/ndb/src/mgmclient/Makefile.am
@@ -0,0 +1,21 @@
+
+ndbtools_PROGRAMS = ndb_mgm
+
+ndb_mgm_SOURCES = \
+ main.cpp \
+ CommandInterpreter.cpp \
+ CpcClient.cpp
+
+include $(top_srcdir)/ndb/config/common.mk.am
+include $(top_srcdir)/ndb/config/type_ndbapi.mk.am
+
+INCLUDES += -I$(top_srcdir)/ndb/include/mgmapi -I$(top_srcdir)/ndb/src/common/mgmcommon
+
+LDADD_LOC = $(top_builddir)/ndb/src/libndbclient.la \
+ $(top_builddir)/ndb/src/common/editline/libeditline.a \
+ @TERMCAP_LIB@
+
+ndb_mgm_LDFLAGS = @ndb_bin_am_ldflags@
+
+# Don't update the files from bitkeeper
+%::SCCS/s.%