summaryrefslogtreecommitdiff
path: root/ndb/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ndb/tools/Makefile.am')
-rw-r--r--ndb/tools/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/ndb/tools/Makefile.am b/ndb/tools/Makefile.am
new file mode 100644
index 00000000000..64625f69ea2
--- /dev/null
+++ b/ndb/tools/Makefile.am
@@ -0,0 +1,36 @@
+
+ndbtools_PROGRAMS = \
+ ndb_waiter \
+ ndb_drop_table \
+ ndb_delete_all \
+ ndb_desc \
+ ndb_drop_index \
+ ndb_show_tables \
+ ndb_select_all \
+ ndb_select_count
+
+tools_common_sources = ../test/src/NDBT_ReturnCodes.cpp ../test/src/NDBT_Table.cpp ../test/src/NDBT_Output.cpp
+
+ndb_waiter_SOURCES = waiter.cpp $(tools_common_sources)
+ndb_delete_all_SOURCES = delete_all.cpp $(tools_common_sources)
+ndb_desc_SOURCES = desc.cpp $(tools_common_sources)
+ndb_drop_index_SOURCES = drop_index.cpp $(tools_common_sources)
+ndb_drop_table_SOURCES = drop_tab.cpp $(tools_common_sources)
+ndb_show_tables_SOURCES = listTables.cpp $(tools_common_sources)
+ndb_select_all_SOURCES = select_all.cpp ../test/src/NDBT_ResultRow.cpp $(tools_common_sources)
+ndb_select_count_SOURCES = select_count.cpp $(tools_common_sources)
+
+include $(top_srcdir)/ndb/config/common.mk.am
+include $(top_srcdir)/ndb/config/type_ndbapitools.mk.am
+
+ndb_waiter_LDFLAGS = @ndb_bin_am_ldflags@
+ndb_drop_table_LDFLAGS = @ndb_bin_am_ldflags@
+ndb_delete_all_LDFLAGS = @ndb_bin_am_ldflags@
+ndb_desc_LDFLAGS = @ndb_bin_am_ldflags@
+ndb_drop_index_LDFLAGS = @ndb_bin_am_ldflags@
+ndb_show_tables_LDFLAGS = @ndb_bin_am_ldflags@
+ndb_select_all_LDFLAGS = @ndb_bin_am_ldflags@
+ndb_select_count_LDFLAGS = @ndb_bin_am_ldflags@
+
+# Don't update the files from bitkeeper
+%::SCCS/s.%