summaryrefslogtreecommitdiff
path: root/netware/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'netware/Makefile.am')
-rw-r--r--netware/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/netware/Makefile.am b/netware/Makefile.am
index 61e7925301d..648ce79c484 100644
--- a/netware/Makefile.am
+++ b/netware/Makefile.am
@@ -46,8 +46,20 @@ link_sources:
@LN_CP_F@ $(srcdir)/$$org ../$$f; \
done
else
-EXTRA_DIST= comp_err.def init_db.sql install_test_db.ncf \
- libmysql.def libmysql.imp \
+
+BUILT_SOURCES = libmysql.imp
+DISTCLEANFILES = $(BUILT_SOURCES)
+
+# Create the libmysql.imp from libmysql/libmysql.def
+libmysql.imp: $(top_srcdir)/libmysql/libmysql.def
+ awk 'BEGIN{x=0;} \
+ END{printf("\n");} \
+ x==1 {printf(" %s",$$1); x++; next} \
+ x>1 {printf(",\n %s", $$1); next} \
+ /EXPORTS/{x=1}' $(top_srcdir)/libmysql/libmysql.def > libmysql.imp
+
+EXTRA_DIST= $(BUILT_SOURCES) comp_err.def init_db.sql install_test_db.ncf \
+ libmysql.def \
libmysqlmain.c my_manage.c my_manage.h \
my_print_defaults.def myisam_ftdump.def myisamchk.def \
myisamlog.def myisampack.def mysql.def mysql.xdc \