summaryrefslogtreecommitdiff
path: root/plugin/auth/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/auth/Makefile.am')
-rw-r--r--plugin/auth/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/plugin/auth/Makefile.am b/plugin/auth/Makefile.am
new file mode 100644
index 00000000000..ed459b7b2b1
--- /dev/null
+++ b/plugin/auth/Makefile.am
@@ -0,0 +1,16 @@
+pkgplugindir=$(pkglibdir)/plugin
+
+AM_LDFLAGS=-module -rpath $(pkgplugindir)
+AM_CPPFLAGS=-DMYSQL_DYNAMIC_PLUGIN -Wno-pointer-sign -I$(top_srcdir)/include
+
+pkgplugin_LTLIBRARIES= auth.la auth_test_plugin.la
+auth_la_SOURCES= dialog.c
+auth_test_plugin_la_SOURCES= test_plugin.c
+
+if HAVE_PEERCRED
+pkgplugin_LTLIBRARIES+= auth_socket.la
+auth_socket_la_SOURCES= auth_socket.c
+endif
+
+EXTRA_DIST= plug.in
+