summaryrefslogtreecommitdiff
path: root/plugin/feedback/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/feedback/Makefile.am')
-rw-r--r--plugin/feedback/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/plugin/feedback/Makefile.am b/plugin/feedback/Makefile.am
new file mode 100644
index 00000000000..7d2a61d593f
--- /dev/null
+++ b/plugin/feedback/Makefile.am
@@ -0,0 +1,18 @@
+pkgplugindir = $(pkglibdir)/plugin
+INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include \
+ -I$(top_srcdir)/regex -I$(top_srcdir)/sql
+
+EXTRA_LTLIBRARIES = feedback.la libfeedback.la
+pkgplugin_LTLIBRARIES = @plugin_feedback_shared_target@
+feedback_la_LDFLAGS = -module -rpath $(pkgplugindir) -L$(top_builddir)/libservices -lmysqlservices
+feedback_la_CXXFLAGS = -shared -DMYSQL_DYNAMIC_PLUGIN
+feedback_la_SOURCES = feedback.cc utils.cc url_base.cc url_http.cc \
+ sender_thread.cc
+
+noinst_LTLIBRARIES = @plugin_feedback_static_target@
+libfeedback_la_SOURCES= feedback.cc utils.cc url_base.cc url_http.cc \
+ sender_thread.cc
+
+noinst_HEADERS = feedback.h
+EXTRA_DIST = CMakeLists.txt plug.in
+