summaryrefslogtreecommitdiff
path: root/plugin/semisync/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/semisync/Makefile.am')
-rw-r--r--plugin/semisync/Makefile.am38
1 files changed, 0 insertions, 38 deletions
diff --git a/plugin/semisync/Makefile.am b/plugin/semisync/Makefile.am
deleted file mode 100644
index ec1ecee46a2..00000000000
--- a/plugin/semisync/Makefile.am
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright (C) 2006 MySQL AB
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; version 2 of the License.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-
-## Makefile.am for semi-synchronous replication
-
-pkgplugindir = $(pkglibdir)/plugin
-INCLUDES = -I$(top_srcdir)/include \
- -I$(top_srcdir)/sql \
- -I$(top_srcdir)/regex \
- -I$(srcdir)
-
-noinst_HEADERS = semisync.h semisync_master.h semisync_slave.h
-
-pkgplugin_LTLIBRARIES = semisync_master.la semisync_slave.la
-
-semisync_master_la_LDFLAGS = -module -rpath $(pkgplugindir) -L$(top_builddir)/libservices -lmysqlservices
-semisync_master_la_CXXFLAGS= $(AM_CXXFLAGS) -DMYSQL_DYNAMIC_PLUGIN
-semisync_master_la_CFLAGS = $(AM_CFLAGS) -DMYSQL_DYNAMIC_PLUGIN
-semisync_master_la_SOURCES = semisync.cc semisync_master.cc semisync_master_plugin.cc
-
-semisync_slave_la_LDFLAGS = -module -rpath $(pkgplugindir) -L$(top_builddir)/libservices -lmysqlservices
-semisync_slave_la_CXXFLAGS= $(AM_CXXFLAGS) -DMYSQL_DYNAMIC_PLUGIN
-semisync_slave_la_CFLAGS = $(AM_CFLAGS) -DMYSQL_DYNAMIC_PLUGIN
-semisync_slave_la_SOURCES = semisync.cc semisync_slave.cc semisync_slave_plugin.cc
-
-EXTRA_DIST= CMakeLists.txt plug.in