summaryrefslogtreecommitdiff
path: root/regex/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'regex/CMakeLists.txt')
-rw-r--r--regex/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/regex/CMakeLists.txt b/regex/CMakeLists.txt
new file mode 100644
index 00000000000..e00f339b3b9
--- /dev/null
+++ b/regex/CMakeLists.txt
@@ -0,0 +1,5 @@
+SET(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -D_DEBUG -DSAFEMALLOC -DSAFE_MUTEX")
+SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -D_DEBUG -DSAFEMALLOC -DSAFE_MUTEX")
+
+INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include)
+ADD_LIBRARY(regex debug.c regcomp.c regerror.c regexec.c regfree.c reginit.c split.c)