summaryrefslogtreecommitdiff
path: root/scripts/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/CMakeLists.txt')
-rw-r--r--scripts/CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
index 0c9177c79c5..56b7f779bb0 100644
--- a/scripts/CMakeLists.txt
+++ b/scripts/CMakeLists.txt
@@ -81,12 +81,9 @@ INSTALL(FILES
)
# TCMalloc hacks
-IF($ENV{MALLOC_LIB})
- SET(MALLOC_LIB $ENV{MALLOC_LIB} CACHE STRING "malloc library")
-ENDIF()
-
IF(MALLOC_LIB)
- INSTALL(FILES ${MALLOC_LIB} DESTINATION lib OPTIONAL)
+ MESSAGE("Using tcmalloc '${MALLOC_LIB}'")
+ INSTALL(FILES ${MALLOC_LIB} DESTINATION ${INSTALL_LIBDIR} OPTIONAL)
ENDIF()
IF(CMAKE_GENERATOR MATCHES "Makefiles")
@@ -313,7 +310,7 @@ IF(WIN32)
FOREACH(file ${SH_FILES})
CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/${file}.sh
${CMAKE_CURRENT_BINARY_DIR}/${file}.pl ESCAPE_QUOTES @ONLY)
- INSTALL_SCRIPT(${CMAKE_CURRENT_BINARY_DIR}/${file}.pl COMPONENT ${${file}_COMPONENT})
+ INSTALL_SCRIPT(${CMAKE_CURRENT_BINARY_DIR}/${file}.pl COMPONENT Server_Scripts)
ENDFOREACH()
ELSE()
# On Unix, most of the files end up in the bin directory