summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 9d344118f2b..0507385500e 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -16,9 +16,9 @@
## Process this file with automake to create Makefile.in
BUILT_SOURCES = mysql_fix_privilege_tables.sql \
- mysql_fix_privilege_tables_sql.c
+ mysql_fix_privilege_tables_sql.c
-noinst_PROGRAMS = comp_sql
+EXTRA_PROGRAMS = comp_sql
bin_SCRIPTS = @server_scripts@ \
msql2mysql \
@@ -62,6 +62,7 @@ EXTRA_DIST = $(EXTRA_SCRIPTS) \
mysqlaccess.conf \
mysqlbug \
make_win_bin_dist \
+ mysql_fix_privilege_tables_sql.c \
mysql_system_tables_fix.sql \
CMakeLists.txt
@@ -87,13 +88,11 @@ CLEANFILES = @server_scripts@ \
mysqlhotcopy \
mysqldumpslow \
mysql_tableinfo \
- mysqld_multi \
- mysql_fix_privilege_tables.sql \
- mysql_fix_privilege_tables_sql.c
+ mysqld_multi
# mysqlbug should be distributed built so that people can report build
# failures with it.
-DISTCLEANFILES = mysqlbug
+DISTCLEANFILES = $(BUILT_SOURCES) mysqlbug
# We want the right version and configure comand line in mysqlbug
mysqlbug: ${top_builddir}/config.status mysqlbug.sh
@@ -109,11 +108,14 @@ mysql_fix_privilege_tables.sql: mysql_system_tables.sql \
#
# Build mysql_fix_privilege_tables_sql.c from
# mysql_fix_privileges_tables.sql using comp_sql
+# The "sleep" ensures the generated file has a younger timestamp than its source
+# (which may have been generated in this very same "make" run).
#
mysql_fix_privilege_tables_sql.c: comp_sql.c mysql_fix_privilege_tables.sql
$(MAKE) $(AM_MAKEFLAGS) comp_sql$(EXEEXT)
+ sleep 2
$(top_builddir)/scripts/comp_sql$(EXEEXT) \
- mysql_fix_privilege_tables \
+ mysql_fix_privilege_tables \
$(top_srcdir)/scripts/mysql_fix_privilege_tables.sql $@