summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am22
1 files changed, 16 insertions, 6 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 1fad4befe6e..d1c3bd82050 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -32,8 +32,7 @@ bin_SCRIPTS = @server_scripts@ \
mysql_explain_log \
mysql_tableinfo \
mysql_upgrade_shell \
- mysqld_multi \
- mysql_create_system_tables
+ mysqld_multi
noinst_SCRIPTS = make_binary_distribution \
make_sharedlib_distribution \
@@ -60,15 +59,18 @@ EXTRA_SCRIPTS = make_binary_distribution.sh \
mysqld_multi.sh \
mysql_tableinfo.sh \
mysql_upgrade_shell.sh \
- mysqld_safe.sh \
- mysql_create_system_tables.sh
+ mysqld_safe.sh
EXTRA_DIST = $(EXTRA_SCRIPTS) \
mysqlaccess.conf \
mysqlbug \
- make_win_bin_dist
+ make_win_bin_dist \
+ mysql_fix_privilege_tables.sql.in
-dist_pkgdata_DATA = fill_help_tables.sql mysql_fix_privilege_tables.sql
+dist_pkgdata_DATA = fill_help_tables.sql \
+ mysql_fix_privilege_tables.sql \
+ mysql_system_tables.sql \
+ mysql_test_data_timezone.sql
# mysqlbug should be distributed built so that people can report build
# failures with it.
@@ -99,6 +101,14 @@ DISTCLEANFILES = mysqlbug
# We want the right version and configure comand line in mysqlbug
mysqlbug: ${top_builddir}/config.status mysqlbug.sh
+# Build mysql_fix_privilege_tables.sql from the files that contain
+# the system tables for this version of MySQL plus any commands
+# needed to upgrade the system tables from an older version
+mysql_fix_privilege_tables.sql: mysql_fix_privilege_tables.sql.in \
+ mysql_system_tables.sql
+ @echo "Building $@";
+ @cat mysql_system_tables.sql $@.in > $@
+
SUFFIXES = .sh
.sh: