summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index d7053a86b3a..e4a75ab4591 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -165,5 +165,19 @@ SUFFIXES = .sh
@CHMOD@ +x $@-t
@MV@ $@-t $@
+
+BUILT_SOURCES = mysql_fix_privilege_tables_sql.c
+noinst_PROGRAMS = comp_sql
+
+#
+# Build mysql_fix_privilege_tables_sql.c from
+# mysql_fix_privileges_tables.sql using comp_sql
+#
+mysql_fix_privilege_tables_sql.c: comp_sql.c mysql_fix_privilege_tables.sql
+ $(MAKE) $(AM_MAKEFLAGS) comp_sql$(EXEEXT)
+ $(top_builddir)/scripts/comp_sql$(EXEEXT) \
+ mysql_fix_privilege_tables.sql $@
+
+
# Don't update the files from bitkeeper
%::SCCS/s.%