summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index d1c3bd82050..cca81cd8818 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -65,15 +65,14 @@ EXTRA_DIST = $(EXTRA_SCRIPTS) \
mysqlaccess.conf \
mysqlbug \
make_win_bin_dist \
- mysql_fix_privilege_tables.sql.in
+ mysql_system_tables_fix.sql
dist_pkgdata_DATA = fill_help_tables.sql \
mysql_fix_privilege_tables.sql \
mysql_system_tables.sql \
+ mysql_system_tables_data.sql \
mysql_test_data_timezone.sql
-# mysqlbug should be distributed built so that people can report build
-# failures with it.
CLEANFILES = @server_scripts@ \
make_binary_distribution \
make_sharedlib_distribution \
@@ -94,8 +93,11 @@ CLEANFILES = @server_scripts@ \
mysql_upgrade_shell \
mysqld_multi \
make_win_src_distribution \
- mysql_create_system_tables
+ mysql_create_system_tables \
+ mysql_fix_privilege_tables.sql
+# mysqlbug should be distributed built so that people can report build
+# failures with it.
DISTCLEANFILES = mysqlbug
# We want the right version and configure comand line in mysqlbug
@@ -104,10 +106,10 @@ mysqlbug: ${top_builddir}/config.status mysqlbug.sh
# Build mysql_fix_privilege_tables.sql from the files that contain
# the system tables for this version of MySQL plus any commands
# needed to upgrade the system tables from an older version
-mysql_fix_privilege_tables.sql: mysql_fix_privilege_tables.sql.in \
- mysql_system_tables.sql
+mysql_fix_privilege_tables.sql: mysql_system_tables.sql \
+ mysql_system_tables_fix.sql
@echo "Building $@";
- @cat mysql_system_tables.sql $@.in > $@
+ @cat mysql_system_tables.sql mysql_system_tables_fix.sql > $@
SUFFIXES = .sh