summaryrefslogtreecommitdiff
path: root/sql-bench/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sql-bench/CMakeLists.txt')
-rw-r--r--sql-bench/CMakeLists.txt58
1 files changed, 32 insertions, 26 deletions
diff --git a/sql-bench/CMakeLists.txt b/sql-bench/CMakeLists.txt
index a837746bb98..b5532b2445c 100644
--- a/sql-bench/CMakeLists.txt
+++ b/sql-bench/CMakeLists.txt
@@ -34,38 +34,44 @@ INSTALL(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/Data/Wisconsin
INSTALL(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/limits
DESTINATION ${prefix}sql-bench COMPONENT SqlBench)
-FILE(GLOB all_files ${CMAKE_CURRENT_SOURCE_DIR}/*)
+SET(all_files README bench-count-distinct.sh bench-init.pl.sh
+ compare-results.sh copy-db.sh crash-me.sh example.bat
+ graph-compare-results.sh innotest1.sh innotest1a.sh innotest1b.sh
+ innotest2.sh innotest2a.sh innotest2b.sh myisam.cnf pwd.bat
+ run-all-tests.sh server-cfg.sh test-ATIS.sh test-alter-table.sh
+ test-big-tables.sh test-connect.sh test-create.sh test-insert.sh
+ test-select.sh test-table-elimination.sh test-transactions.sh
+ test-wisconsin.sh uname.bat
+ )
FOREACH(file ${all_files})
- IF(NOT IS_DIRECTORY ${file} AND NOT ${file} MATCHES "Make|as3ap|/example$" )
- GET_FILENAME_COMPONENT(ext ${file} EXT)
- GET_FILENAME_COMPONENT(name ${file} NAME)
- SET(target ${name})
- IF(ext MATCHES ".sh$")
- # Those are perl files actually
- STRING(REPLACE ".sh" "" target ${target} )
- IF(WIN32)
- IF(NOT ext MATCHES ".pl")
- SET(target "${target}.pl")
- ENDIF()
+ GET_FILENAME_COMPONENT(ext ${file} EXT)
+ GET_FILENAME_COMPONENT(name ${file} NAME)
+ SET(target ${name})
+ IF(ext MATCHES ".sh$")
+ # Those are perl files actually
+ STRING(REPLACE ".sh" "" target ${target} )
+ IF(WIN32)
+ IF(NOT ext MATCHES ".pl")
+ SET(target "${target}.pl")
ENDIF()
ENDIF()
- SET(target "${CMAKE_CURRENT_BINARY_DIR}/${target}")
- CONFIGURE_FILE(${file} ${target} COPYONLY)
- IF (UNIX AND NOT ${name} MATCHES "README")
- EXECUTE_PROCESS(COMMAND chmod +x ${target})
- ENDIF()
- IF (ext MATCHES ".bat")
- IF(WIN32)
- INSTALL(PROGRAMS ${target}
- DESTINATION ${prefix}sql-bench COMPONENT SqlBench)
- ENDIF()
- ELSEIF(name MATCHES "README")
- INSTALL(FILES ${target}
- DESTINATION ${prefix}sql-bench COMPONENT SqlBench)
- ELSE()
+ ENDIF()
+ SET(target "${CMAKE_CURRENT_BINARY_DIR}/${target}")
+ CONFIGURE_FILE(${file} ${target} COPYONLY)
+ IF (UNIX AND NOT ${name} MATCHES "README")
+ EXECUTE_PROCESS(COMMAND chmod +x ${target})
+ ENDIF()
+ IF (ext MATCHES ".bat")
+ IF(WIN32)
INSTALL(PROGRAMS ${target}
DESTINATION ${prefix}sql-bench COMPONENT SqlBench)
ENDIF()
+ ELSEIF(name MATCHES "README")
+ INSTALL(FILES ${target}
+ DESTINATION ${prefix}sql-bench COMPONENT SqlBench)
+ ELSE()
+ INSTALL(PROGRAMS ${target}
+ DESTINATION ${prefix}sql-bench COMPONENT SqlBench)
ENDIF()
ENDFOREACH()