summaryrefslogtreecommitdiff
path: root/sql/share/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sql/share/Makefile.am')
-rw-r--r--sql/share/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/sql/share/Makefile.am b/sql/share/Makefile.am
index e662c4f09a2..2f1440597dc 100644
--- a/sql/share/Makefile.am
+++ b/sql/share/Makefile.am
@@ -1,16 +1,14 @@
## Process this file with automake to create Makefile.in
-ERRMSG=$(patsubst %, %/errmsg.sys, @AVAILABLE_LANGUAGES@)
-
# This requires gnu cp at distribution time.
dist-hook:
for lang in @AVAILABLE_LANGUAGES@ charsets; \
do cp -a $(srcdir)/$$lang $(distdir); done
-all: $(ERRMSG)
+all: @AVAILABLE_LANGUAGES_ERRORS@
-$(ERRMSG): %.sys: %.txt
- ../../extra/comp_err $< $@
+# this is ugly, but portable
+@AVAILABLE_LANGUAGES_ERRORS_RULES@
install-data-local:
for lang in @AVAILABLE_LANGUAGES@; \