summaryrefslogtreecommitdiff
path: root/storage/blackhole/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'storage/blackhole/CMakeLists.txt')
-rw-r--r--storage/blackhole/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/storage/blackhole/CMakeLists.txt b/storage/blackhole/CMakeLists.txt
new file mode 100644
index 00000000000..a90f8e14ca0
--- /dev/null
+++ b/storage/blackhole/CMakeLists.txt
@@ -0,0 +1,7 @@
+SET(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -DSAFEMALLOC -DSAFE_MUTEX")
+SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DSAFEMALLOC -DSAFE_MUTEX")
+
+INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include ${CMAKE_SOURCE_DIR}/sql
+ ${CMAKE_SOURCE_DIR}/regex
+ ${CMAKE_SOURCE_DIR}/extra/yassl/include)
+ADD_LIBRARY(blackhole ha_blackhole.cc ha_blackhole.h)