summaryrefslogtreecommitdiff
path: root/storage/blackhole/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'storage/blackhole/Makefile.am')
-rw-r--r--storage/blackhole/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/storage/blackhole/Makefile.am b/storage/blackhole/Makefile.am
index b417c900f11..7ebd8a92e19 100644
--- a/storage/blackhole/Makefile.am
+++ b/storage/blackhole/Makefile.am
@@ -58,14 +58,14 @@ DTRACEPROVIDER = probes_mysql.d
dtrace_files:
echo $(DTRACEFILES) > $@
-dtrace_providers: dtrace_sources
+dtrace_providers: probes_mysql.d
echo $(DTRACEPROVIDER) > $@
-dtrace_sources:
+probes_mysql.d:
-$(RM) -f probes_mysql.d
$(CP) $(top_srcdir)/include/probes_mysql.d probes_mysql.d
echo timestamp > dtrace_sources
-probes_mysql.o: $(DTRACEPROVIDER) $(DTRACEFILES) dtrace_sources
+probes_mysql.o: $(DTRACEPROVIDER) $(DTRACEFILES)
$(DTRACE) $(DTRACEFLAGS) -G -s $(DTRACEPROVIDER) $(DTRACEFILES) -o $@
endif