summaryrefslogtreecommitdiff
path: root/storage/csv/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'storage/csv/Makefile.am')
-rw-r--r--storage/csv/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/storage/csv/Makefile.am b/storage/csv/Makefile.am
index 5e3587c893f..76e683ec282 100644
--- a/storage/csv/Makefile.am
+++ b/storage/csv/Makefile.am
@@ -32,7 +32,7 @@ noinst_HEADERS = ha_tina.h transparent_file.h
EXTRA_LTLIBRARIES = ha_csv.la
pkglib_LTLIBRARIES = @plugin_csv_shared_target@
ha_csv_la_LDFLAGS = -module -rpath $(MYSQLLIBdir)
-ha_csv_la_CXXFLAGS = $(AM_CXXFLAGS) -DMYSQL_PLUGIN
+ha_csv_la_CXXFLAGS = -shared $(AM_CXXFLAGS) -DMYSQL_PLUGIN
ha_csv_la_SOURCES = transparent_file.cc ha_tina.cc
EXTRA_LIBRARIES = libcsv.a