summaryrefslogtreecommitdiff
path: root/storage/heap/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'storage/heap/CMakeLists.txt')
-rwxr-xr-x[-rw-r--r--]storage/heap/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/storage/heap/CMakeLists.txt b/storage/heap/CMakeLists.txt
index 39953684b8f..fd3ce149b2c 100644..100755
--- a/storage/heap/CMakeLists.txt
+++ b/storage/heap/CMakeLists.txt
@@ -20,8 +20,13 @@ INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include ${CMAKE_SOURCE_DIR}/zlib
${CMAKE_SOURCE_DIR}/sql
${CMAKE_SOURCE_DIR}/regex
${CMAKE_SOURCE_DIR}/extra/yassl/include)
-ADD_LIBRARY(heap _check.c _rectest.c hp_block.c hp_clear.c hp_close.c hp_create.c
+
+SET(HEAP_SOURCES _check.c _rectest.c hp_block.c hp_clear.c hp_close.c hp_create.c
ha_heap.cc
hp_delete.c hp_extra.c hp_hash.c hp_info.c hp_open.c hp_panic.c
hp_rename.c hp_rfirst.c hp_rkey.c hp_rlast.c hp_rnext.c hp_rprev.c
hp_rrnd.c hp_rsame.c hp_scan.c hp_static.c hp_update.c hp_write.c)
+
+IF(NOT SOURCE_SUBLIBS)
+ ADD_LIBRARY(heap ${HEAP_SOURCES})
+ENDIF(NOT SOURCE_SUBLIBS)