summaryrefslogtreecommitdiff
path: root/storage/innobase/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'storage/innobase/CMakeLists.txt')
-rw-r--r--storage/innobase/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/storage/innobase/CMakeLists.txt b/storage/innobase/CMakeLists.txt
index 90a01540000..7d255531b15 100644
--- a/storage/innobase/CMakeLists.txt
+++ b/storage/innobase/CMakeLists.txt
@@ -194,8 +194,6 @@ IF(MSVC)
TARGET_COMPILE_OPTIONS(innobase PRIVATE "/wd4065")
ENDIF()
-ADD_SUBDIRECTORY(${CMAKE_SOURCE_DIR}/extra/mariabackup ${CMAKE_BINARY_DIR}/extra/mariabackup)
-
-IF(TARGET innobase)
- ADD_DEPENDENCIES(innobase GenError)
+IF(NOT (PLUGIN_INNOBASE STREQUAL DYNAMIC))
+ ADD_SUBDIRECTORY(${CMAKE_SOURCE_DIR}/extra/mariabackup ${CMAKE_BINARY_DIR}/extra/mariabackup)
ENDIF()