summaryrefslogtreecommitdiff
path: root/storage/tokudb/PerconaFT/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'storage/tokudb/PerconaFT/CMakeLists.txt')
-rw-r--r--storage/tokudb/PerconaFT/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/storage/tokudb/PerconaFT/CMakeLists.txt b/storage/tokudb/PerconaFT/CMakeLists.txt
index 3973ec71b52..a0918e505b1 100644
--- a/storage/tokudb/PerconaFT/CMakeLists.txt
+++ b/storage/tokudb/PerconaFT/CMakeLists.txt
@@ -9,9 +9,13 @@ project(TokuDB)
set(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
set(CMAKE_SHARED_LIBRARY_LINK_CXX_FLAGS "")
+# See: https://jira.percona.com/browse/TDB-93
+MY_CHECK_AND_SET_COMPILER_FLAG("-Wno-address-of-packed-member")
+
# detect when we are being built as a subproject
if (DEFINED MYSQL_PROJECT_NAME_DOCSTRING)
- add_definitions( -DMYSQL_TOKUDB_ENGINE=1)
+ add_definitions(-DMYSQL_TOKUDB_ENGINE=1)
+ add_definitions(-DMYSQL_VERSION_ID=${MYSQL_VERSION_ID})
# Extended PFS instrumentation:
# -DTOKU_PFS_MUTEX_EXTENDED_CACHETABLEMMUTEX=1
if (WITH_PERFSCHEMA_STORAGE_ENGINE)