summaryrefslogtreecommitdiff
path: root/storage/tokudb/PerconaFT/buildheader/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'storage/tokudb/PerconaFT/buildheader/CMakeLists.txt')
-rw-r--r--storage/tokudb/PerconaFT/buildheader/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/storage/tokudb/PerconaFT/buildheader/CMakeLists.txt b/storage/tokudb/PerconaFT/buildheader/CMakeLists.txt
new file mode 100644
index 00000000000..d9629f2cc68
--- /dev/null
+++ b/storage/tokudb/PerconaFT/buildheader/CMakeLists.txt
@@ -0,0 +1,29 @@
+set_directory_properties(PROPERTIES INCLUDE_DIRECTORIES "")
+
+file(WRITE "${CMAKE_CURRENT_BINARY_DIR}/runcat.sh" "#!/bin/bash
+out=$1; shift
+exec \"$@\" >$out")
+
+add_executable(make_tdb make_tdb)
+set_property(TARGET make_tdb APPEND PROPERTY COMPILE_DEFINITIONS _GNU_SOURCE)
+add_custom_command(
+ OUTPUT "${CMAKE_CURRENT_BINARY_DIR}/db.h"
+ COMMAND bash runcat.sh "${CMAKE_CURRENT_BINARY_DIR}/db.h" $<TARGET_FILE:make_tdb>
+ DEPENDS make_tdb)
+add_custom_target(install_tdb_h DEPENDS
+ "${CMAKE_CURRENT_BINARY_DIR}/db.h")
+
+# detect when we are being built as a subproject
+if (NOT DEFINED MYSQL_PROJECT_NAME_DOCSTRING)
+ install(
+ FILES "${CMAKE_CURRENT_BINARY_DIR}/db.h"
+ DESTINATION include
+ RENAME tokudb.h
+ COMPONENT tokukv_headers
+ )
+ install(
+ FILES "${CMAKE_CURRENT_BINARY_DIR}/db.h"
+ DESTINATION include
+ COMPONENT tokukv_headers
+ )
+endif () \ No newline at end of file