summaryrefslogtreecommitdiff
path: root/storage/xtradb/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'storage/xtradb/CMakeLists.txt')
-rw-r--r--storage/xtradb/CMakeLists.txt13
1 files changed, 8 insertions, 5 deletions
diff --git a/storage/xtradb/CMakeLists.txt b/storage/xtradb/CMakeLists.txt
index f5ec6fd746d..96856a92239 100644
--- a/storage/xtradb/CMakeLists.txt
+++ b/storage/xtradb/CMakeLists.txt
@@ -62,9 +62,6 @@ IF(UNIX)
LINK_LIBRARIES(${AIO_LIBRARY})
ENDIF()
ADD_DEFINITIONS("-DUNIV_LINUX -D_GNU_SOURCE=1")
- IF(HAVE_LIBNUMA)
- LINK_LIBRARIES(numa)
- ENDIF()
ELSEIF(CMAKE_SYSTEM_NAME MATCHES "HP*")
ADD_DEFINITIONS("-DUNIV_HPUX")
ELSEIF(CMAKE_SYSTEM_NAME STREQUAL "AIX")
@@ -505,9 +502,15 @@ IF(CMAKE_SYSTEM_PROCESSOR MATCHES "ppc64le")
)
ENDIF()
+UNSET(NUMA_LIBRARY)
+IF(HAVE_LIBNUMA)
+ SET(NUMA_LIBRARY "numa")
+ENDIF()
+
MYSQL_ADD_PLUGIN(xtradb ${INNOBASE_SOURCES} STORAGE_ENGINE
- DEFAULT RECOMPILE_FOR_EMBEDDED
- LINK_LIBRARIES ${ZLIB_LIBRARY} ${LINKER_SCRIPT})
+ DEFAULT
+ RECOMPILE_FOR_EMBEDDED
+ LINK_LIBRARIES ${ZLIB_LIBRARY} ${NUMA_LIBRARY} ${LINKER_SCRIPT})
IF(TARGET xtradb)
IF(NOT XTRADB_OK)