summaryrefslogtreecommitdiff
path: root/vio/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vio/Makefile.am')
-rw-r--r--vio/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/vio/Makefile.am b/vio/Makefile.am
index c1a69b26058..e8b226adb37 100644
--- a/vio/Makefile.am
+++ b/vio/Makefile.am
@@ -15,10 +15,13 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
INCLUDES = -I$(srcdir)/../include -I../include $(openssl_includes)
-LDADD = libvio.a $(openssl_libs)
+LDADD = libvio.a $(openssl_libs)
pkglib_LIBRARIES = libvio.a
-noinst_PROGRAMS =
+noinst_PROGRAMS = viotest-ssl
noinst_HEADERS =
+viotest_ssl_SOURCES = viotest-ssl.c
+viotest_ssl_LDADD = ../dbug/libdbug.a libvio.a ../mysys/libmysys.a ../strings/libmystrings.a \
+ libvio.a $(openssl_libs)
libvio_a_SOURCES = vio.c viosocket.c viossl.c viosslfactories.c
OMIT_DEPENDENCIES = pthread.h stdio.h __stdio.h stdlib.h __stdlib.h math.h\