From 0bfc8c57ca2f3c5e8f56e12604eb94e1dc47ec9f Mon Sep 17 00:00:00 2001
From: unknown <tomas@poseidon.ndb.mysql.com>
Date: Tue, 1 Jun 2004 11:19:40 +0000
Subject: various ndb make changes, see respective file

BitKeeper/deleted/.del-Makefile.am~d4e228ebd21fc066:
  Delete: ndb/include/Makefile.am
acinclude.m4:
  static linking of ndbclient into mysqld
configure.in:
  removed ndb/include/Makefile.am + fixed conditional compile of ndb shm, sci
ndb/Makefile.am:
  dist-hook for make distdir in ndb
ndb/config/type_ndbapitest.mk.am:
  use of libndbclient.so in testprograms
ndb/config/type_ndbapitools.mk.am:
  static linking to binary distributed ndb tools
ndb/src/Makefile.am:
  enable libndbclient.so
ndb/src/common/transporter/Makefile.am:
  added support for optional inclusion of shared mem and sci in ndb transporter
ndb/tools/Makefile.am:
  new type for tools which should be statically linked with libndbclient
BitKeeper/etc/logging_ok:
  Logging to logging@openlogging.org accepted
---
 configure.in | 14 +++++++++++---
 1 file changed, 11 insertions(+), 3 deletions(-)

(limited to 'configure.in')

diff --git a/configure.in b/configure.in
index 87b2862d5e3..b1234721354 100644
--- a/configure.in
+++ b/configure.in
@@ -2919,8 +2919,16 @@ AC_SUBST(mgmapiincludedir)
   AC_SUBST(NDB_NDBAPICLIENT_INCLUDES)
   AC_SUBST(NDB_MGMAPICLIENT_INCLUDES)
 
-AM_CONDITIONAL(HAVE_NDB_SHM, test X"$have_ndb_shm" = Xyes)
-AM_CONDITIONAL(HAVE_NDB_SCI, test X"$have_ndb_sci" = Xyes)
+ndb_transporter_opt_objs=""
+if test X"$have_ndb_shm" = Xyes
+then
+  ndb_transporter_opt_objs="$(ndb_transporter_opt_objs) SHM_Transporter.lo SHM_Transporter.unix.lo"
+fi
+if test X"$have_ndb_sci" = Xyes
+then
+  ndb_transporter_opt_objs="$(ndb_transporter_opt_objs) SCI_Transporter.lo"
+fi
+AC_SUBST(ndb_transporter_opt_objs)
 
   #NDB_TYPE_COMMON="include \$(top_srcdir)/ndb/config/common.mk.am"
   #NDB_TYPE_NDBAPI="include \$(top_srcdir)/ndb/config/type_ndbapi.mk.am"
@@ -2937,7 +2945,7 @@ AC_SUBST(MAKE_BINARY_DISTRIBUTION_OPTIONS)
 
 # Output results
 AC_OUTPUT(Makefile extra/Makefile mysys/Makefile isam/Makefile dnl
-   ndb/Makefile ndb/include/Makefile ndb/src/Makefile ndb/src/common/Makefile dnl
+   ndb/Makefile ndb/src/Makefile ndb/src/common/Makefile dnl
    ndb/tools/Makefile dnl
    ndb/src/common/debugger/Makefile ndb/src/common/debugger/signaldata/Makefile dnl
    ndb/src/common/portlib/Makefile ndb/src/common/portlib/unix/Makefile dnl
-- 
cgit v1.2.1