summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 6 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index c6ee5bf..d3067df 100644
--- a/setup.py
+++ b/setup.py
@@ -22,18 +22,18 @@ class ve_build_ext(build_ext):
def run(self):
try:
build_ext.run(self)
- except DistutilsPlatformError:
- raise BuildFailed()
+ except DistutilsPlatformError as e:
+ raise BuildFailed() from e
def build_extension(self, ext):
try:
build_ext.build_extension(self, ext)
- except (CCompilerError, DistutilsExecError, DistutilsPlatformError):
- raise BuildFailed()
- except ValueError:
+ except (CCompilerError, DistutilsExecError, DistutilsPlatformError) as e:
+ raise BuildFailed() from e
+ except ValueError as e:
# this can happen on Windows 64 bit, see Python issue 7511
if "'path'" in str(sys.exc_info()[1]): # works with Python 2 and 3
- raise BuildFailed()
+ raise BuildFailed() from e
raise