summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Phillips <electrum@gmail.com>2005-01-14 22:05:16 +0000
committerDavid Phillips <electrum@gmail.com>2005-01-14 22:05:16 +0000
commitb585e734f7cd0b11809d039a35fd46d51a9904fb (patch)
tree51ff8a8335ab48a90f46a2ca8128d4ac90fc1ea9 /Makefile.am
parentbf9a7d2b528e922466dc75f6fdeb0736a7c850b1 (diff)
downloadmemcached-b585e734f7cd0b11809d039a35fd46d51a9904fb.tar.gz
patch from David Phillips <electrum@gmail.com>
Here is a patch to configure.ac and Makefile.am to put the man page in the correct location. Trying to install the man page from a subdirectory results in the subdirectory being used in the install path (it tries to install to doc/memcached.1). This is the correct thing to do: - create a Makefile.am in the doc directory that installs the man page with man_MANS - modify Makefile.am in the base directory to reference the doc directory using SUBDIRS - modify the AC_CONFIG_FILES macro in configure.ac to output the Makefile in doc git-svn-id: http://code.sixapart.com/svn/memcached/trunk@234 b0b603af-a30f-0410-a34e-baf09ae79d0b
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index cc8fbed..4ef0c25 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,10 +2,9 @@ bin_PROGRAMS = memcached
memcached_SOURCES = memcached.c slabs.c items.c memcached.h assoc.c
-DIST_SUBDIRS = doc scripts
+SUBDIRS = doc
+DIST_DIRS = scripts
EXTRA_DIST = doc scripts TODO
-man_MANS = doc/memcached.1
-
AM_CFLAGS=-DNDEBUG