summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDustin Sallings <dustin@spy.net>2009-07-09 10:31:17 -0700
committerdormando <dormando@rydia.net>2009-07-09 10:47:35 -0700
commit5419eb03a3c3840f71c2f46bb66156a99ab29b74 (patch)
tree1bbbaeef4ab0d18956b8fe71fc9ebdae221ed65f /configure.ac
parenta13bf0fbeda6dbb125f06620255b3888868f711c (diff)
downloadmemcached-5419eb03a3c3840f71c2f46bb66156a99ab29b74.tar.gz
Disable strict aliasing (issue 60)
This allows compilation to succeed in gcc 4.4 at a potential performance cost for which we can come up with a better solution post 1.4.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 65b0252..2ef2073 100644
--- a/configure.ac
+++ b/configure.ac
@@ -364,7 +364,7 @@ then
AC_DEFINE([_GNU_SOURCE],[1],[find sigignore on Linux])
elif test "$GCC" = "yes"
then
- CFLAGS="$CFLAGS -Wall -Werror -pedantic -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls"
+ CFLAGS="$CFLAGS -Wall -Werror -pedantic -fno-strict-aliasing -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls"
AC_DEFINE([_GNU_SOURCE],[1],[find sigignore on Linux])
elif test "$SUNCC" = "yes"
then