summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTrond Norbye <Trond.Norbye@sun.com>2009-03-10 13:52:07 +0100
committerTrond Norbye <Trond.Norbye@sun.com>2009-03-10 13:52:07 +0100
commit6ddbbfd00bff93c5b452b80fec3d1a777adc5977 (patch)
tree262166027ffc5720176e4ecccc135b10fb24b59d /configure.ac
parent528cf973b6961a14f2749d632bd0b268e34142e1 (diff)
downloadmemcached-6ddbbfd00bff93c5b452b80fec3d1a777adc5977.tar.gz
Fix output from DETECT_ICC macro when $GCC != "yes"
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9c9991a..a3b1d24 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,11 +21,13 @@ AC_DEFUN([DETECT_ICC],
dnl check if this is icc acting as gcc in disguise
AC_EGREP_CPP([^__INTEL_COMPILER], [__INTEL_COMPILER],
AC_MSG_RESULT([no])
- [$2]
- ICC="no",
+ [$2],
AC_MSG_RESULT([yes])
[$1]
ICC="yes")
+ else
+ AC_MSG_RESULT([no])
+ [$2]
fi
])