summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBrad Fitzpatrick <brad@danga.com>2003-12-30 19:56:33 +0000
committerBrad Fitzpatrick <brad@danga.com>2003-12-30 19:56:33 +0000
commit4b1b1ae76ef6e78dd3f1d753931ac8051ae99e9a (patch)
tree27b41e3c67e55ecce5ec7d16ac13caaf0ce333be /configure.ac
parentf2049d4e3efb8fc3b6659e785c97c349b1f0b916 (diff)
downloadmemcached-4b1b1ae76ef6e78dd3f1d753931ac8051ae99e9a.tar.gz
version 1.1.10:
2003-12-30 (Brad) * remove static build stuff. interferes with PAM setuid stuff and was only included as a possible fix with the old memory allocator. really shouldn't make a difference. * release version 1.1.10 git-svn-id: http://code.sixapart.com/svn/memcached/trunk@176 b0b603af-a30f-0410-a34e-baf09ae79d0b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 1 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 7c5fea3..af21115 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
AC_PREREQ(2.52)
-AC_INIT(memcached, 1.1.10pre, brad@danga.com)
+AC_INIT(memcached, 1.1.10, brad@danga.com)
AC_CANONICAL_SYSTEM
AC_CONFIG_SRCDIR(memcached.c)
AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
@@ -50,29 +50,6 @@ fi
AC_C_SOCKLEN_T
-dnl Default to building a static executable.
-AC_ARG_ENABLE(static,
- AC_HELP_STRING([--disable-static],[build a dynamically linked executable]),
- , enable_static=yes)
-AC_MSG_CHECKING(whether to build a static executable)
-
-dnl Darwin can't do static binaries
-case "$host" in
- *-darwin*)
- enable_static=no
- ;;
- *)
- ;;
-esac
-
-if test "$enable_static" = "no"; then
- STATIC=
- AC_MSG_RESULT(no)
-else
- CFLAGS="$CFLAGS -static"
- AC_MSG_RESULT(yes)
-fi
-
AC_CHECK_FUNCS(mlockall)
AC_CONFIG_FILES(Makefile)