summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTrond Norbye <Trond.Norbye@sun.com>2009-09-16 14:03:44 +0200
committerDustin Sallings <dustin@spy.net>2009-09-18 14:27:47 -0700
commit73628d3e9ae44b14ef31412e7b7d82507d2e7f30 (patch)
treefdf7e6a64af164a7534ced1b6fea6ea93ad8abeb /configure.ac
parent69743bd52c97cf96c01a9a2ea8395cfda0d9118d (diff)
downloadmemcached-73628d3e9ae44b14ef31412e7b7d82507d2e7f30.tar.gz
Add support for hugetlbfs (for Linux).
From http://libhugetlbfs.ozlabs.org/ - libhugetlbfs is a library which provides easy access to huge pages of memory. It is a wrapper for the hugetlbfs file system. If you are running memcached with a very large heap in Linux, this change will make it available to you. The hugetlbfs HOWTO provides detailed information on how to configure your Linux system and provide advice to applications (such as memcached) to make use of it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 74d3f59..53127c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -231,6 +231,7 @@ dnl ----------------------------------------------------------------------------
AC_SEARCH_LIBS(socket, socket)
AC_SEARCH_LIBS(gethostbyname, nsl)
AC_SEARCH_LIBS(umem_cache_create, umem)
+AC_SEARCH_LIBS(gethugepagesizes, hugetlbfs)
AC_HEADER_STDBOOL
AC_C_CONST