summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDustin Sallings <dustin@spy.net>2009-02-13 14:22:36 -0800
committerDustin Sallings <dustin@spy.net>2009-02-13 14:22:36 -0800
commit725c26fbcd63f7ef13f13c5eb84933db98273fd6 (patch)
tree03743d49cac0f6ee8d109aa543126dd58a6052a5 /configure.ac
parent74e80c7b2f2e43f9c2d174fe54ae792d0e4a6fb5 (diff)
downloadmemcached-725c26fbcd63f7ef13f13c5eb84933db98273fd6.tar.gz
Workaround Solaris autoconf interaction to look for C99.
The ICC check seems to abort prematurely, so doing the test from within the function doesn't work. Instead, get the vars set, and do the check based on the var values.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 9 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 7436f7d..a35d158 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,23 +20,20 @@ AC_DEFUN([DETECT_ICC],
if test "$GCC" = "yes"; then
dnl check if this is icc acting as gcc in disguise
AC_EGREP_CPP([^__INTEL_COMPILER], [__INTEL_COMPILER],
- dnl action if the text is found, this it has not been replaced by the
- dnl cpp
- ICC="no"
- [$2],
- dnl the text was not found, it was replaced by the cpp
- ICC="yes"
+ AC_MSG_RESULT([no])
+ [$2]
+ ICC="no",
AC_MSG_RESULT([yes])
[$1]
- )
- fi
- if test "$ICC" = "no"; then
- # this is not ICC
- AC_MSG_RESULT([no])
+ ICC="yes")
fi
])
-DETECT_ICC([], [AC_PROG_CC_C99])
+DETECT_ICC([], [])
+
+if test "$ICC" == "no"; then
+ AC_PROG_CC_C99
+fi
AM_PROG_CC_C_O
AC_PROG_INSTALL