summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlberts Muktupāvels <alberts.muktupavels@gmail.com>2015-09-20 02:06:59 +0300
committerAlberts Muktupāvels <alberts.muktupavels@gmail.com>2015-09-20 02:06:59 +0300
commite2d6beadb342732a149da1d6b92b854ff908ad5c (patch)
tree8c29fc89810562acaa28b1db8ae328a9ca95cd57 /configure.ac
parentc151c4c672d90c46b23d1f7a59e344fa6dfedb5c (diff)
downloadmetacity-e2d6beadb342732a149da1d6b92b854ff908ad5c.tar.gz
build: add AX_CHECK_ENABLE_DEBUG
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 487ed103..4e158c9d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,6 +31,12 @@ dnl **************************************************************************
AX_IS_RELEASE([git-directory])
dnl **************************************************************************
+dnl Enable debug
+dnl **************************************************************************
+
+AX_CHECK_ENABLE_DEBUG([yes])
+
+dnl **************************************************************************
dnl Initialize automake
dnl **************************************************************************
@@ -442,13 +448,6 @@ if test x"$ZENITY" = xno; then
AC_MSG_ERROR([zenity not found in your path - needed for dialogs])
fi
-AC_ARG_ENABLE(debug,
- [ --enable-debug enable debugging],,
- enable_debug=no)
-if test "x$enable_debug" = "xyes"; then
- CFLAGS="$CFLAGS -g -O"
-fi
-
# Warnings are there for a reason
if test "x$GCC" = "xyes"; then
CFLAGS="$CFLAGS -Wall -ansi"