summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorElijah Newren <newren gmail com>2006-02-27 22:11:56 +0000
committerElijah Newren <newren@src.gnome.org>2006-02-27 22:11:56 +0000
commit6a08faf99b908218a9ec8fadf03b12362e449251 (patch)
tree4b1be4b46ee5f38505294cd1bc04639a693fafd4 /configure.in
parenta3e7c9c222d1bf9a5b77c54bfccd82cf8301aec3 (diff)
downloadmetacity-6a08faf99b908218a9ec8fadf03b12362e449251.tar.gz
Patch from Sylvain Bertrand to fix build issues with library search order.
2006-02-27 Elijah Newren <newren gmail com> * configure.in: Patch from Sylvain Bertrand to fix build issues with library search order. #330695.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index ff012742..23a09fc9 100644
--- a/configure.in
+++ b/configure.in
@@ -404,10 +404,10 @@ if test "x$found_xsync" = "xyes"; then
AC_DEFINE(HAVE_XSYNC, , [Have the Xsync extension library])
fi
-METACITY_LIBS="$XSYNC_LIBS $RANDR_LIBS $SHAPE_LIBS $X_LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS $METACITY_LIBS"
-METACITY_MESSAGE_LIBS="$X_LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS $METACITY_MESSAGE_LIBS"
-METACITY_WINDOW_DEMO_LIBS="$X_LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS $METACITY_WINDOW_DEMO_LIBS"
-METACITY_PROPS_LIBS="$X_LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS $METACITY_PROPS_LIBS"
+METACITY_LIBS="$METACITY_LIBS $XSYNC_LIBS $RANDR_LIBS $SHAPE_LIBS $X_LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS"
+METACITY_MESSAGE_LIBS="$METACITY_MESSAGE_LIBS $X_LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS"
+METACITY_WINDOW_DEMO_LIBS="$METACITY_WINDOW_DEMO_LIBS $X_LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS"
+METACITY_PROPS_LIBS="$METACITY_PROPS_LIBS $X_LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS"
found_sm=no
case "$METACITY_LIBS" in