summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-11-16 04:20:17 +0000
committerHavoc Pennington <hp@src.gnome.org>2003-11-16 04:20:17 +0000
commit901ad18a6780faecfb6fc1f9ee5026b6fdfe0717 (patch)
treea1de9b38826ec72bce7dc87dccbb3d37b90c4209 /configure.in
parent6ac67f80a6bac067f3314434dfd48bf7d547e763 (diff)
downloadmetacity-901ad18a6780faecfb6fc1f9ee5026b6fdfe0717.tar.gz
fix warning
2003-11-15 Havoc Pennington <hp@redhat.com> * src/main.c (main): fix warning * src/compositor.c: add a new file to contain compositing manager functionality; not yet implemented at all.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 29 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1ef70a16..af00938f 100644
--- a/configure.in
+++ b/configure.in
@@ -125,6 +125,8 @@ AC_ARG_ENABLE(sm, [ --disable-sm disable metacity's session m
AC_ARG_ENABLE(startup-notification, [ --disable-startup-notification disable metacity's startup notification support, for embedded/size-sensitive custom non-GNOME builds],,enable_startup_notification=auto)
+AC_ARG_ENABLE(compositor, [ --disable-compositor disable metacity's compositing manager],,enable_compositor=auto)
+
AC_ARG_ENABLE(xsync, [ --disable-xsync disable metacity's use of the XSync extension],,enable_xsync=auto)
AC_ARG_ENABLE(shape, [ --disable-shape disable metacity's use of the shaped window extension],,enable_shape=auto)
@@ -175,6 +177,32 @@ else
echo "Building without libstartup-notification"
fi
+XCOMPOSITE_VERSION=1.0
+AC_MSG_CHECKING([Xcomposite >= $XCOMPOSITE_VERSION])
+if $PKG_CONFIG --atleast-version $XCOMPOSITE_VERSION xcomposite; then
+ have_xcomposite=yes
+else
+ have_xcomposite=no
+fi
+AC_MSG_RESULT($have_xcomposite)
+
+if test x$enable_compositor = xyes; then
+ have_xcomposite=yes
+ echo "CompositeExt support forced on"
+elif test x$enable_compositor = xauto; then
+ true
+else
+ have_xcomposite=no
+fi
+
+if test x$have_xcomposite = xyes; then
+ echo "Building with CompositeExt"
+ METACITY_PC_MODULES="$METACITY_PC_MODULES xcomposite >= $XCOMPOSITE_VERSION xfixes xrender"
+ AC_DEFINE(HAVE_XCOMPOSITEENSIONS, , [Building with compositing manager support])
+else
+ echo "Building without compositing manager"
+fi
+
PKG_CHECK_MODULES(METACITY, $METACITY_PC_MODULES)
AC_PATH_XTRA
@@ -399,6 +427,7 @@ metacity-$VERSION:
XFree86 Xinerama: ${use_xfree_xinerama}
Solaris Xinerama: ${use_solaris_xinerama}
Startup notification: ${have_startup_notification}
+ Compositing manager: ${have_xcomposite}
Session management: ${found_sm}
Shape extension: ${found_shape}
Resize-and-rotate: ${found_randr}