summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Clasen <matthiasc@src.gnome.org>2005-07-18 04:13:12 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2005-07-18 04:13:12 +0000
commitb6fa0deff3fb83264e55cb3064041f57a7aaae03 (patch)
tree59897fbd0a968bda331067b4541e0d6ea695eb63 /configure.in
parent10ee3e89dcf1a37022605a9e8d6b1ed82a0c049e (diff)
downloadmetacity-b6fa0deff3fb83264e55cb3064041f57a7aaae03.tar.gz
Forgotten configure changes for the cursor theme changes.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 4ea0ac82..6c3814c0 100644
--- a/configure.in
+++ b/configure.in
@@ -258,6 +258,20 @@ if test x$have_xrender = xyes; then
AC_DEFINE(HAVE_RENDER, , [Building with Render extension support])
fi
+AC_MSG_CHECKING([Xcursor])
+if $PKG_CONFIG xcursor; then
+ have_xcursor=yes
+ else
+ have_xcursor=no
+ fi
+ AC_MSG_RESULT($have_xcursor)
+
+if test x$have_xcursor = xyes; then
+ echo "Building with Xcursor"
+ METACITY_PC_MODULES="$METACITY_PC_MODULES xcursor"
+ AC_DEFINE(HAVE_XCURSOR, , [Building with Xcursor support])
+fi
+
PKG_CHECK_MODULES(METACITY, $METACITY_PC_MODULES)
AC_PATH_XTRA
@@ -498,6 +512,7 @@ metacity-$VERSION:
Resize-and-rotate: ${found_randr}
Xsync: ${found_xsync}
Render: ${have_xrender}
+ Xcursor: ${have_xcursor}
"
echo "This is the UNSTABLE branch of metacity"
echo "Use 2.10.x for stable (gnome-2-10 branch in CVS)"